LPC flag in Access database?

Comments

10 comments

  • Avatar
    DougO
    First off, I am a little confused as to how you are implementing the impact vector. When an impact vector is imported, it should set the LPP (Local Direct Purchase in the premade templates) = Trade Flow ...if the LPP in the imported data is a value less then 1.0 (<100%). If it doesn't work that way let me know.
    0
    Comment actions Permalink
  • Avatar
    Swinter
    Sorry, I wasn't clear. It's when I stick stuff in the IMPLANModelTemplate. It comes in with whatever LPCs are in the tables there, it doesn't update to the model LPCs/RPCs. Is there some flag I can use?
    0
    Comment actions Permalink
  • Avatar
    DougO
    Hmph.. are the current values less than 1.0? Send a sample to me so I can try it out, please.
    0
    Comment actions Permalink
  • Avatar
    Swinter
    [attachment=171]SPF IMPLANModelTemplate.zip[/attachment]
    0
    Comment actions Permalink
  • Avatar
    DougO
    k, Susan. I renamed your database to .impdb and tried to import the household activities and kept getting an error about null fields. I was able to fix it, and when I import the household sectors from that model into a new model the LPP's are reset to the current model. However, the events were not sorted so it appeared to have LPP's all over the board if you did not note the sector numbers. If you sort (click on the "sector" header field) that problem clears up.
    0
    Comment actions Permalink
  • Avatar
    Swinter
    Can you try this - 1) In your System folder rename IMPLANModelTemplate something like "Original IMPLANModelTemplate". Then rename the file I sent you IMPLANModelTemplate and put it in the System folder. 2) Build a model. That stuffs all my activities and scenarios in the new model. I somehow want the LPCs to be set to the model RPCs as the model is built. Maybe that's not possible.
    0
    Comment actions Permalink
  • Avatar
    DougO
    Hah, now I think I understand what you are trying to do. No, that is not possible. The model won't automatically reset event LPPs in existing impact vectors every time social accounts and multipliers are constructed - it may undo work that a user wants to keep.
    0
    Comment actions Permalink
  • Avatar
    Swinter
    Ok, thanks for checking!!! Another question - sometimes when I do Event Options/Change All it runs really fast. Other times it's really slow - this is for the same Activity in different models. Is there any way to make it run fast? Can I do something in Access rather than in IMPLAN? That might be faster.
    0
    Comment actions Permalink
  • Avatar
    DougO
    This was something that Scott looked at a while ago and couldn't come up with a solution. When I try to update all events in an activity that holds a lot of events it always runs slow - I'd like to know how you get it to run fast sometimes. Anyway, one thing to try, is to import the 9 activities to the current model from a holding model (you can shift-click to highlight and import all 9 at once)- this automatically updates the LPPs. It may be faster.
    0
    Comment actions Permalink
  • Avatar
    Swinter
    That's a good suggestion. Thank you!
    0
    Comment actions Permalink

Please sign in to leave a comment.